Fehlermeldungen beim Starten von ACA2017

  • Hallo zusammen


    Ich bin ganz neu auf den P3Dv4 umgestiegen. Nachdem ich nun soweit meinen Ai Traffic mehr oder weniger zusammen gestellt habe, benutze ich zur Fehlersuche das sehr nützliche ACA2017 Tool.

    Beim Aufstarten kommen jetzt jeweils zwei Fehlermeldungen.

    1. The following SimObject Folders are listed in your cfg or XML files but where not found on your System! C:\Lockheed Martin\Prepare3D v4\..\data\SimObjects.

    2. The following Scenery Folders are listed in your cfg or XML files but whre not found on your System! scenery\world


    Diese waren vor ein paar Tagen noch nicht erschienen. Zudem benutze ich den Addon-Organizer von Lorby-Si und dort wird alles grün angezeigt (d.h. es fehlt nichts

    Ebenfalls habe ich sowohl im C:\Users\User\AppData\Roaming\Lockheed Martin\Prepar3D v4 sowie im C:\ProgramData\Lockheed Martin\Prepar3D v4 die dll.xml sowie exe durchgeschaut. Diese beiden Pfade sind gar nicht eingetragen. Auch in der P3d.cfg und Simobject.cfg nicht.


    Habt Ihr hier einen Tipp?


    Besten Dank schonmal

    Lg
    Patrick

  • Hi


    Leider werden beide Pfade nicht vollständig angezeigt.

    Beim einen ist nur scenery\world beim anderen hat es ... dazwischen.


    Grüsse

    Patrick

  • 1. ..\data\SimObjects.

    2. scenery\world

    Beide Verzeichnisnamen erscheinen mir zumindest seltsam. dll.xml, exe.xml, prepar3d.cfg und simobjects.cfg haben damit nichts zu tun.


    In den beiden add-ons.cfg Dateien stehen Verweise auf add-on.xml Dateien, in denen dann wieder die Ordner aufgerufen werden, in denen die Daten sind, die der Sim laden soll.


    \data\SimObjects sucht nach SimObjects, die dort nicht sind, obwohl eine add-on.xml es behauptet.

    scenery\world sucht nach den traffic-bgl-Dateien für den AI und meint wohl das Verzeichnis scenery\world\scenery im Sim-Ordner. Das wäre dann aber ein relativer Link; damit müsste die add-on.xml im Sim-Hauptordner liegen (eher unwahrscheinlich und in jedem Fall unüblich).

    Vermutlich stehen beide falschen Verweise in der gleichen add-on.xml.


    Also schau erst mal in den beiden add-ons.cfg Dateien (eine in \appdata\roaming, eine in \ProgramData, dann jeweils Lockhheed Martin\Prepar3d v4) ob du dort einen package-Eintrag findest, der auf AI Traffic verweist. Der Eintrag sagt dir wo du die zugehörige add-on.xml findest.


    Dann schaust du dir die an und gleichst das mit der Ordnerstruktur ab, die diese add-on-xml aufrufen will. Am sichersten ist immer der absolute Pfad (also alles ab dem Laufwerksbuchstaben).

  • Hallo Boris


    Vielen Dank, das brachte mich schon viel weiter. Leider komme ich heute nicht mehr dazu, es genauer anzuschauen.

    die scenery\world ist von FSDG Mauritius. Werde morgen versuchen den Pfad zu ändern.


    Die zweite Datei data\SimObjects habe ich noch nicht gefunden.


    Melde mich morgen wieder.


    Lg

    Patrick

  • Also ich habe dank dem Hinweis von Boris veide Dateien gefunden.

    Die sceney/world ist von FSDG Mauritius die Zweite Simobject von Sode.


    Ich habe dann in der XML den vollständigen Pfad inkl. Laufwerk angegeben. Jetzt ist die Meldung weg.


    Lg

    Patrick