P3D V3.4 wg D3DCOMPILER_47.dll crashed

  • Hallo Flusigemeinde,


    derzeit stürzt nach der Auswahl des Szenarios jedes mal der P3D ab. In der Ereignisanzeige von Windows 10 erhalte ich die Info, dass das Modul "D3DCOMPILER_47.dll" dazu führte. Im Internet finde ich dazu nichts konkretes, bzw. immer nur, dass man diese DLL austauschen solle (das wird aber grundsätzlich für jede DLL geraten, die zu einem Crash führte.. nicht sonderlich vertrauensvoll).


    Hoffe, dass evtl. hier mir jmd helfen kann. Beim zweiten Start funktioniert dann wieder alles.


    P3D V3.4, Win 10 Prof 64 Bit, diverse AddOns, im Moment beim Laden von AS A321 Modell, AS16+ASCA.


    Gruss

    Thomas

    Europäisch fliegen mit Airbus | Preferred on VATSIM (ID: 861603) |DLHvirtual

    CPU:i9-9900K | GPU:RTX2080Ti | RAM:32GB | 1TB-SSD | OS:W10 Prof | FSLabs@P3D5


    861603

  • Moin,


    hm, einige empfehlen bei solchen und ähnlichen Fehlern (D3DCOMPILER_43.dll), das aktuelle DX11 zu installieren. Jetzt bin ich fast der Überzeugung, bei Windows 10 wird doch alles aktuell gehalten (kumulative Patches beinhalten alle Fehlerbereinigungen, also auch für DX11, oder?), d.h. wenn ich z.B. den PC an einem früheren Systemzeitpunkt zurücksetze, und damit auch zu einer früheren Patchversion (wobei ich das bezweifel... aber egal), dann nutzt mir doch auch eine Aktualisierung von Dx11 nichts, oder liege ich da jetzt völlig falsch?


    Grüße

    Thomas

    Europäisch fliegen mit Airbus | Preferred on VATSIM (ID: 861603) |DLHvirtual

    CPU:i9-9900K | GPU:RTX2080Ti | RAM:32GB | 1TB-SSD | OS:W10 Prof | FSLabs@P3D5


    861603

  • Nun, ich gehe davon aus, dass Du nicht de reinzigste sein wirst... ;-) Ich hege aber die Hoffnung, dass vielleicht ein anderer ein ähnliches Problem hatte und dies zumindest für mich Laien erklärbar machen könnte, wie ich das eindämmen könnte...

    Europäisch fliegen mit Airbus | Preferred on VATSIM (ID: 861603) |DLHvirtual

    CPU:i9-9900K | GPU:RTX2080Ti | RAM:32GB | 1TB-SSD | OS:W10 Prof | FSLabs@P3D5


    861603

  • Nun, ich gehe davon aus, dass Du nicht de reinzigste sein wirst... ;-) Ich hege aber die Hoffnung, dass vielleicht ein anderer ein ähnliches Problem hatte und dies zumindest für mich Laien erklärbar machen könnte, wie ich das eindämmen könnte...

    Stimmt, ich habe genau das selbe Problem, finde aber bisher nirgends eine Lösung gefunden. Aufgetreten ist das Problem nach der Installation von P3DV5.1 HF1 und Installation der FSL Busse.

    Wäre auch dankbar wenn jemand helfen könnte.

    Grüsse aus EDDM Raymond

    WIN 10 64, I5 4690K 4,40 GHz , VGA Palit GeForce® GTX 1080 8GB Dual OC, P3D V5

  • Ja, hab ich gesehen, ändert aber nichts an der Tatsache, dass ich das Problem jetzt habe.

    Wenn jemand zufällig noch die Lösung von damals noch kennt, würde es mir möglicherweise weiter helfen.

    Grüsse aus EDDM Raymond

    WIN 10 64, I5 4690K 4,40 GHz , VGA Palit GeForce® GTX 1080 8GB Dual OC, P3D V5

  • Moin,


    hm, ich erinnere mich nicht mehr wirklich an das Problem, aber im wesentlichen unternehme ich folgende Schritte, wenn mich etwas nervt:


    - Shaders löschen

    - P3D-Config Datei löschen und neu erstellen lassen (Vorsicht: wenn Du SimStarter nutzt, dann musst Du das ein oder andere beachten)


    Wenn das nichts hilft, dann entweder die Suche eingrenzen, in dem man das ein oder andere AddOn deaktiviert oder aber, und ich glaube, dass habe ich dann so gemacht, eine Neuinstallation durchführen, wenn das Problem bei der Fehlersuche nicht eingegrenzt werden kann.


    Ist halt wirklich sehr lange her, aber wenn ich nicht mehr dazu hier geschrieben hatte, habe ich wohl obige Schritte durchgeführt, bis es wieder lief.


    Viele Grüße

    Thomas

    Europäisch fliegen mit Airbus | Preferred on VATSIM (ID: 861603) |DLHvirtual

    CPU:i9-9900K | GPU:RTX2080Ti | RAM:32GB | 1TB-SSD | OS:W10 Prof | FSLabs@P3D5


    861603